Here’s the Deal with BBM 7 for BlackBerry OS 4.5 and Above

BBM-7-Voice

Previously, we reported that BBM 7 was available for BlackBerry devices running OS 4.5 and above. Turns out, it wasn’t quite available just yet. We’ve had quite a few people asking where it’s available. Here’s an official statement from RIM:

“Thanks for your interest in BBM 7, which is currently available for all BlackBerry smartphones running the BlackBerry 6 OS or higher. Support is planned at a future date for smartphones running the BlackBerry 5 OS, so keep a look out for updates from us.”

While no definitive date has been set, if you’re a BlackBerry user on OS 5 you can expect BBM 7 in the future. Unfortunately, it looks as though BBM 7 will not be available for OS 4.5.




Leave a Reply