N4BB
According to BlackBerry Application Center there is an update for VZ Navigator. The older version (4.2.21.40) will be replaced with version 4.2.21.56, however, there’s a catch. Once you go to install the update it will take you to this:

So you click install, it takes you to the BlackBerry page where you agree to the User Agreement and it prompts you to download. Ahh wait! It shows it wants to download old version? Low and behold, it will not download. I’m not sure if either Verizon or RIM is aware of this, but it is showing the old verison, which is giving us a ‘907 Missing COD’ error. Wonder why? Hopefully, they will resolve this soon.

ADVERTISEMENT