With the launch of the Passport, the P’9983, BlackBerry 10 OS 10.3, and Blend, it seemed like an appropriate time to clear up some confusion as to what you can and can’t use with your current BlackBerry 10 smartphone that may be in your hand.

As you may remember from May of this year, BlackBerry let everyone know that the 10.3 OS update would not be making its way to current in-market devices. They have reconfirmed this at today’s event. This is due to the fact that BlackBerry 10 OS 10.3.1 was chosen as the next update for all BlackBerry 10 devices, not 10.3.

ADVERTISEMENT

Unfortunately, for a new program like Blend, you need at least BlackBerry 10.3 on your BlackBerry smartphone. This means unless you load up a 10.3 leak on your Z10, Q10, Q5, Z30, or Z3, you will not be able to use Blend until 10.3.1 is launched and approved by your carrier. If you pick up a new Passport, or P’9983, however, Blend will work without any issues.

Again, this is nothing new, but it needed to be emphasized as we’ve seen countless number of people asking when 10.3 is going to be available for their device and/or why Blend isn’t working for them yet.